Tested on OpenBSD 6.3 and 6.4

Upgrade OpenBSD on bare metal

If you have OpenBSD installed and want to upgrate it, then backup your data first.

Prepare

Download and verify install64.fs:

# ftp -V https://cdn.openbsd.org/pub/OpenBSD/6.4/amd64/install64.fs
install64.fs 100% |*******************************|  360 MB     00:34
# ftp -V https://cdn.openbsd.org/pub/OpenBSD/6.4/amd64/SHA256.sig
SHA256.sig   100% |*******************************|  2141       00:00
# signify -C -p /etc/signify/openbsd-64-base.pub -x SHA256.sig install64.fs
Signature Verified
install64.fs: OK
#

Read the official FAQ.

Update your configuration files, if needed for 6.4.

Create bootable USB drive

Plug in a USB drive:

# dmesg | grep removable | tail -n1
sd3 at scsibus5 targ 1 lun 0: ... removable serial.12345...
#

In this case it appears as sd3. Copy the installer image to the USB flash drive (be extremely cautious):

# dd if=install64.fs of=/dev/rsd3c bs=1m
...

Upgrade

Boot from that USB drive, then choose the (S)hell option to mount the encrypted drive.

# bioctl -c C -l /dev/sd0a softraid0
passphrase:
scsibus1 at softraid0: 1 targets
sd3 at scsibus2 targ 0 lun 0: <OPENBSD, SR RAID 1, 005> SCSI2 0/direct fixed
sd3: 10244MB, 512 bytes/sec, 20980362 sec total
# exit

Choose (U)pgrade and answer the questions.

Which disk is the root disk = sd3
Location of sets = disk

Update packages

Login and update the installed packages:

# pkg_add -uv
...
#